Mitsubishi Connect - Mitsubishi Eclipse Cross Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 11-04-2018, 09:30 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 10
Mitsubishi Connect

Is anyone having trouble connecting to their vehicle through the Mitsubishi Connect service? Every time I try, something always goes wrong or it’s unable to connect. I don’t know what to do for trouble shooting.
[email protected] is offline  
post #2 of 6 (permalink) Old 11-05-2018, 08:00 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 10
Fun news update.

Apparently my TCU needs to be replaced. I’ve had the vehicle for 5 days. This makes me question it holding up over time.
[email protected] is offline  
post #3 of 6 (permalink) Old 03-29-2019, 10:54 AM
Member
 
slippercream's Avatar
 
Join Date: Oct 2018
Location: Austin, TX
Posts: 61
I've never been able to get the Mitsubishi Connect app to work quickly and reliably.
I can list a whole litany of reasons why the app sucks, but how would that change anything? And, perhaps, some of it is hardware-related, too (meaning, it's what's in the car that isn't working).

But either way, the implementation of this feature, IMHO, puts a dent in anything "innovative" about the **** product.
I imagine what it's going to be like with the new Dendo Drive House feature they're going to release next year. Now I have to connect BOTH my house and car to this sh*tty network?

Sorry to hear about your TCU.
slippercream is offline  
post #4 of 6 (permalink) Old 10-16-2019, 11:55 AM
Junior Member
 
Join Date: Sep 2018
Posts: 4
I've had my EC for just over a year and early on, the app was crap (Android Pixel 2). There have been a number of updates since and it seems to be running a bit smoother. They did put fingerprint authentication on which helps with having to reenter that long-assed PW every time. I did find that if you have not used the vehicle for a few days, the car seems to go into a "sleep mode" regarding the remote access.
teesquar is offline  
post #5 of 6 (permalink) Old Yesterday, 04:48 PM
Junior Member
 
betha_b1's Avatar
 
Join Date: Jan 2020
Location: North Dakota, United States
Posts: 19
This system is so worthless. Im shocked they can't come out with something better. Mine constantly says it's started but hasn't. Then when it does start it reloads and indicates it hasn't. I stopped using it at all. I'll stick with my fob autostart. It also can't tell me where my car is, but it will show me on the map, lol.
betha_b1 is online now  
post #6 of 6 (permalink) Old Yesterday, 08:50 PM
Member
 
Lunatic59's Avatar
 
Join Date: Nov 2019
Location: Pennsylvania | USA
Posts: 54
Garage
Quote:
Originally Posted by betha_b1 View Post
This system is so worthless. Im shocked they can't come out with something better. Mine constantly says it's started but hasn't. Then when it does start it reloads and indicates it hasn't. I stopped using it at all. I'll stick with my fob autostart. It also can't tell me where my car is, but it will show me on the map, lol.
I had that happen to me, too. I think the software connecting to the app is incredibly buggy, but they keep working on it. I actually used the Mitsubishi Connect info button in the cabin to report the issue and they reached out to me by email (as requested). For the maps thing try this ...

1. Login To the My Mitsubishi Connect App
2. Click on the Settings icon
3. Once the Account Setting screen appears, please click on the "Manage Vehicles" section
4. On the Manage Vehicles screen, please toggle the setting for "Privacy Mode" until you see the grey section on the right of the switch turn red. You will need to enter your PIN for the setting to be modified and after the option has been enabled, you will receive a notification that "Privacy Mode enabled successfully"
5. Next, turn the privacy mode off. You will slide the button back to the left and you will see the red on the right of the button return to grey. You will receive a notification that "Privacy Mode disabled successfully"
6. Now back out of the Manage Vehicles section using the arrows until you have the icons at the bottom of the screen.
7. Click on the icon that looks like an arrow pointing up to the right, enter your PIN and the location of your vehicle should appear. If you get an error, please note the exact message you receive and reply to this message. Log out of the app completely and log back into the app and try the Car Finder remote operation again.

While it took a few tries for me to be able to turn on/off privacy mode, it did finally update and it fixed the location problem. The rest of it works for me as long as I have a decent cell or wifi signal.

This signature intentionally left blank.
Lunatic59 is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure Your Mitsubishi Eclipse Cross EclipseAdmin 2018+ Mitsubishi Eclipse Cross News 1 10-30-2019 10:10 AM
2018-2019 Mitsubishi Eclipse Cross Recall: Safety Systems may be Disabled When in Use EclipseAdmin Mitsubishi Eclipse Cross Recalls 4 11-29-2018 10:41 AM
2018 Mitsubishi Eclipse Cross Overview EclipseAdmin 2018+ Mitsubishi Eclipse Cross News 0 07-25-2018 01:32 PM
2018 Mitsubishi Eclipse Cross Walk Around Video Darryl Henry Mitsubishi Eclipse Cross Videos 4 03-18-2018 05:09 PM
Mitsubishi Eclipse Cross Debuts In LA Eclipse Cross News 2018+ Mitsubishi Eclipse Cross News 5 01-17-2018 03:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome