Eclipse Cross Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello people

Wanted to see if anyone is having any delayed starting issues with the key start not push button. When I put the key in and turn the key nothing happens but if you keep it turned, it will eventuality start. Starts every time it does this but it is annoying for a newer vehicle with less than 30,000km. Dealer here in Canada keeps re flashing the key thinking this is the issue but it keeps happening. Does not happen every time I would say about 50% of the time. Anyone have this issue and got it fixed? Thank you

2019 Mitsubishi Eclipse Cross ES
 

·
Super Moderator
Joined
·
502 Posts
Can't say I've heard of this one before. Do you get any kind of error code on the display? When you turn the key do you hear any clicking like a relay or solenoid is trying to engage or is it dead quiet?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Can't say I've heard of this one before. Do you get any kind of error code on the display? When you turn the key do you hear any clicking like a relay or solenoid is trying to engage or is it dead quiet?

No error codes at all..even the dealer hooked it up to computer and nothing. When the key is turned no sound at all.
 

·
Registered
Joined
·
108 Posts
I would lean on faulty starter or starter relay. Also check the poles in your battery esp. the positive one, see if they are tight or you have too much grease between the poles and the clamps causing poor connection.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I would lean on faulty starter or starter relay. Also check the poles in your battery esp. the positive one, see if they are tight or you have too much grease between the poles and the clamps causing poor connection.
Yeah I mentioned the starter to the dealer and the relay they said if there is no codes they won't change it. Meanwhile they can see the issue too lol. Didn't check the battery but worth a look I will check it. Thank you.
 

·
Registered
Joined
·
108 Posts
Yeah I mentioned the starter to the dealer and the relay they said if there is no codes they won't change it. Meanwhile they can see the issue too lol. Didn't check the battery but worth a look I will check it. Thank you.
I'd look on the relay since I had a relay that prematurely failed on the AC on mine......it was a known issue on that relay model causing premature failure, bought a pulled better one made by Omron from ebay.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I'd look on the relay since I had a relay that prematurely failed on the AC on mine......it was a known issue on that relay model causing premature failure, bought a pulled better one made by Omron from ebay.
Ok, I will give that a try. So on ebay it's called the ac relay or starter relay? I can only see oem radiator fan relay for 18-19 eclipse cross?
 

·
Registered
Joined
·
108 Posts
Ok, I will give that a try. So on ebay it's called the ac relay or starter relay? I can only see oem radiator fan relay for 18-19 eclipse cross?
May have to do some digging on the model of the particular relay before ordering anything....not sure if it's in the manual...I'll try looking and let you know..
 

·
Registered
Joined
·
108 Posts
Ok, I will give that a try. So on ebay it's called the ac relay or starter relay? I can only see oem radiator fan relay for 18-19 eclipse cross?
seems like this should be the relay for the starter....https://www.mitsubishipartswarehouse.com/oem-parts/mitsubishi-relay-mr515994?c=Zz1lbGVjdHJpY2FsJnM9ZnVzZS1hbmQtcmVsYXkmbD0xMyZuPUFzc2VtYmxpZXMgUGFnZSZhPW1pdHN1YmlzaGkmbz1lY2xpcHNlLWNyb3NzJnk9MjAxOSZ0PXNwJmU9MS01bC1sNC1nYXM%3D
 

·
Super Moderator
Joined
·
502 Posts
It could be the lock that's got the problem and not the key, too. If the relay doesn't fix it, I'd ask the dealer to check the switch itself on the lock.
 

·
Registered
Joined
·
106 Posts
I’ve noticed if I let the car sit say 5 days or more sometimes the first turn it doesn’t start and seems like you have a dead battery. But second try always starts right up. Only happens when it sits a bit too. Kinda weird. So far not a big deal. Except for the initial ah shit the battery is dead.
 

·
Registered
Joined
·
1 Posts
Needed to check whether anybody is generally disapproving of the key beginning not press button. At the point when I put the key in and turn the key nothing occurs except for on the off chance that you keep it turned, it will possibility start. Begins each time it does this however it is irritating for a more up to date vehicle with under 30,000km. Vendor here in Canada keeps re blazing the key reasoning this is the issue however it continues to work out. Doesn't occur each time I would agree around half of the time. Anybody have this issue and sorted it out? Much obliged to you
 
1 - 14 of 14 Posts
Top