Eclipse Cross Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
my coolant level is at the low mark on the resovior . is this normal? i know i need to add some and also its blue ? do you need to add some once in a while? what cooolant do i use i never seen blue coloerd. i have the 2019 es 1.5 turbo
 

·
Super Moderator
Joined
·
381 Posts
Is this when the engine is cold or warm? Also, is it right at the LOW mark or below it? Anything between FULL and LOW is okay, even being right at LOW. If you want to top it off, the manual recommends:


Use “Mitsubishi Motors Genuine Super Long Life Coolant Premium” or equivalent*.
*: similar high quality ethylene glycol based non-silicate, non-amine, non-nitrate and non-borate coolant with long life hybrid organic acid technology.


Quite a mouthful. The blue is just dye they put in the official Mitsubishi coolant to make it look different.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
h
Is this when the engine is cold or warm? Also, is it right at the LOW mark or below it? Anything between FULL and LOW is okay, even being right at LOW. If you want to top it off, the manual recommends:


Use “Mitsubishi Motors Genuine Super Long Life Coolant Premium” or equivalent*.
*: similar high quality ethylene glycol based non-silicate, non-amine, non-nitrate and non-borate coolant with long life hybrid organic acid technology.


Quite a mouthful. The blue is just dye they put in the official Mitsubishi coolant to make it look different.
it is when its cold it is right at the low mark , just checking to see if its using it some where evaporating or leaking.
 

·
Super Moderator
Joined
·
381 Posts
Probably just that it was filled warm the last time it was topped off. When warm the overflow will get a bit higher and then pull coolant back in as it cools down. Just keep an eye on it for a few hundred miles and if it doesn't change, you're okay.
 
1 - 4 of 4 Posts
Top