Eclipse Cross Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi Everyone...I live in Las Vegas and it is finally getting over the 100 mark here. My last car I had Hyundai Veloster, would have computer issues anytime it was hot outside. I am now having issues with my 2019 Cross. The days it’s been over 100+ degrees it will say Drivers Assistance Camera Temporarily Unavailable. I’m not sure if it has to do with the heat or not, it’s just the days it is hot this happens. I had taken my Cross in a couple of months ago for the FCM camera having issues and Mitsubishi just told me there is nothing wrong but to understand when it’s hot that the heat waves can make the cameras malfunction and there is nothing that can be done!? Really!? Anyone else having an issue. I’m having a hard time believing that living in the desert is making every car computer system malfunction.
 

·
Registered
Joined
·
329 Posts
Hi, I've been reading around the web of similar issues. I did have a strangeness in my EC the day I picked it up at the dealer but this was to do with the FCM giving a ghost BRAKE! warning which happened as I came towards a large white panel truck that was shining bright because of the sun on it. Hasn't happened again but I keep reading similar reports in other forums.

The camera equipment is mounted in the top of the windscreen and is susceptible to high heat from the sun. Try parking in a shady spot. Knowing Las Vegas as I do I am sure my location in Australia will get to the same temps as you in the future. 40C temps (110F) are quite common for me here in summer.

Also be aware that any dash cams should NOT be mounted centrally under the rear view mirror as the GPS function and electrical interference causes problems with the equipment used by all of the safety systems. There is a warning in the owners manual somewhere...
 

·
Registered
Joined
·
2 Posts
hi there,
I had the same message of "Drivers Assistance Camera Temporarily Unavailable"and this happened when my EC was parked for more than one hour under direct sun and 30 min the motor was ON for AC. Temp was 48C

anyway the message disappear when I parked in a shady area for 2 hours

It is annoying thing when you feel that your new car is not functioning well in your area
 

·
Registered
Joined
·
162 Posts
Having the reveres problem here as we had a very heavy frost the other night. Scrapped the frost of the windscreen but must have left some as on the screen as I got a similar message saying Camera view blocked.
Temperature around -1C
 

·
Registered
Joined
·
40 Posts
I see similar warning these days in especially foggy nights. I think some mist on the windshield blocks the camera even though i use the wipers but i am not sure about that.
 
1 - 5 of 5 Posts
Top