Eclipse Cross Forum banner

1 - 20 of 37 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Is anyone else having issues with smelling gas and / or engine oil not only in the passenger compartment but also when you walk in front of the car and also under the hood? It usually occurs after it is warmed up or driven for a little while. Any thoughts? I can’t find anything leaking anywhere.
 

·
Registered
Joined
·
64 Posts
Did you maybe spill some oil on the engine when you were topping up the oil (or even just measuring the oil with the dipstick)?
 

·
Registered
Joined
·
64 Posts
Gas and hot engine oil actually smell distinctly different. Perhaps sniffing a sample of each will help you to narrow it down.
 

·
Registered
Joined
·
2 Posts
I'm having gas odors from the inside and outside of my Eclipse Cross too. It has been going on for the past 3 months. My wife gets headaches from it and it's getting to where she doesn't even want to be in it. We've even had people at the outside of it ask if we had a fuel leak.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
The technician could not duplicate the smell. When I picked it up I smelled it again as soon as I hit the key. I went back in and got the technician and he again could not smell it. But my wife was complaining about it the whole way home.
He said he checked it all over and there were no leaks of fluid at all. I am going to look for myself tonight.
 

·
Registered
Joined
·
64 Posts
Here are some ideas:

- Is the smell coming through the air conditioning system? Switch off the fan, and see if the smell is there. Switch the fan on to "full", and see if the smell appears or disappears.

- Do you have the AWD version which (in the UK anyway) has no spare tyre but comes with an aerosol repair can. Is the gunk leaking from the can?

- Are you sure it's not the smells that are emitted by new upholstery for the first few months?

It's very odd for a smell to be present inside and outside a vehicle at the same time. Usually it's one or the other.
 

·
Registered
Joined
·
5 Posts
I've had my 2019 EC for about 6 months now and still get the oil smell, but not the fuel smell. At first I thought it was just factory oils being burned off, but after 6 months they should be long gone. I'm wondering if it is related to the turbo.
 

·
Registered
Joined
·
5 Posts
I've had my 2019 EC for about 6 months now and still get the oil smell, but not the fuel smell. At first I thought it was just factory oils being burned off, but after 6 months they should be long gone. I'm wondering if it is related to the turbo.
EDIT: I remember hearing about letting turbos cool down before shutting the car off. Looked it up and there are varying opinions with it depending on if you're really stepping on it or doing an easy drive right before shut down. Times range from around a minute to 3-5 minutes if you've been hitting it hard. Going to try tonight when I get home (if I remember) and let it sit for a minute to see what happens. The burnt oil smell usually hangs for a while in my closed garage.
 

·
Registered
Joined
·
22 Posts
HI ,

Meine Smells too, it is not Gas, it is not motor oil, it is a strange Smell Like heated Transmission oil, Some strange chemical substance smell, and I can feel in inside and when I go infant of the hood outside , I can smell it there as well.

it happens when I park the car for some minutes and then start it again. So I don't think that it has anything to do with Turbo to cool down, in these 5 to 10 minutes which the car was off Turbo is already cool down.

I am suspecting low CVT oil , or in my opinion it has something to do with Transmission temperature.

The Problem is that The Cars are like children when they see the Dr the suddenly get healthy in seconds. I took my EC to Dealer as well and they couldn't smell any thing Although I could smell it.
 

·
Registered
Joined
·
1 Posts
My wife and I both have 2018 Crosses (separate dealers bought about 4 weeks apart). And BOTH of them have this odor issue. I've yet to figure out what it is and my local dealer is not familiar with any other such reports. I'm glad to see others have been having the issue as well.

I characterize the small as a hot oil type smell. Nothing has ever dripped from the cars and both of the cars have over 3500 miles on them.

The smell is most intense after we drive home, park in the garage, and shut the garage door. Going back into the garage 5-10 minutes later, the smell hits you in the face. The smell also will get into the cabin of the car if sitting (car running but not moving) with the fan running.

We're making appointments with the dealer to try and come to a solution, but would love it if someone would have had this problem and also share what the 'fix' was!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #16
yellowmazdamp3. That is exactly what I am trying to describe. Only difference is that I can smell it after I drive it for any distance to heat it up and I can smell it while it is idling and sitting in the car. In other words, when I dropped my wife off at the store and then waited for her.

I did take mine in with this complaint. Dealer said that they couldn’t smell it.
 

·
Registered
Joined
·
15 Posts
The smell of gas enters the cabin of mine also. Strongest during idle. My un-educated guess, it’s due to design, the location air is being drawn from. I replaced the cabin filter (in the glove box) with a higher quality one that stock. Dramatic difference! Recirculating the cabin air seems to stop the smell too.
 

·
Registered
Joined
·
1 Posts
Took ours to the dealership they said nothing leaking. They tightened a couple clamps and said nothing was wrong. The minute I started it to leave the smell filled the cabin! Our garage wreaks of gas after shutting off! Don’t know what to do
 

·
Registered
Joined
·
1 Posts
Has anyone solved this problem yet. on another forum it has been sujested that fuel vent hoses may need to be replaced. am concerned
 

·
Registered
Joined
·
3 Posts
At first,big HELOO to ALL forum-dudes on this forum.Second,forgive me on my bad English speak,bc,im write from Germany.. :D

This problem with smell,i have to..but..ONLY when i start car very sharp..Smell is not gas,not oil at all,not fluid in aircond,bc.AC not in this moment working..

My mashine is gas,163PS,manual...and official energy fluid is Eurosuper E10,what means, 10% bio ethanol..smell in cabin is so "alcoholic"..just on short period..
Maybe is problem just brand new engine and all instalation,which MAYBE not all firmly fixed..
MAYBE gas+ethanol,wenn comming in turbine(direct injection) make very big pressure,and in next CIRCLE,wenn TURBINE is open for AIR,small part ethanol going out,then with air for normal circulation and vent sistem going in cabine...

ATTENTION...

This was i writen,is JUST MY GUESS,and not take like expert advice...just one possibility..


check all conection...air,gas,turbocompressor seal,rubber hose..and firmly pinched,if is not enough

Engine in Eclipse Cross is last word of tech,and is it possibly thad had "childs deseas" in construct...

I want to all,manny mileage and pleasure in driving Mitsubishi Eclipse Cross.. :)
 
1 - 20 of 37 Posts
Top