Eclipse Cross Forum banner

1 - 10 of 10 Posts

·
Registered
2018 Mitsubishi Eclipse Cross SE
Joined
·
4 Posts
Discussion Starter · #1 ·
Just a small introduction of myself and my experience with my vehicle, I am a first time Mitsubishi owner let alone new to the EC. I own a black 2019 EC SE. It's fairly base except for a few additions, honestly what is a base model these days? I do have the My Mitsubishi Connect App and honestly I dont really care for it other than the remote start, which can be finicky. The first couple weeks I owned it, it worked(even though takes forever to actually start), although I let the car sit for a couple days and the remote start stopped working. I gave it 2 days to see if it was something with the service, such as changing the location where I start the vehicle(home and work). I ended up calling them, using the call service in the vehicle(new to that feature which kind of surprised me). They fixed it that day saying they were getting a few calls about the same issue. Assume it was something on their end. That was a few months ago and has yet to be an issue. Also, is there a way to allow the car to stay running longer than 10 min? That is such a low start up time in my opinion, my wife has a 2018 ford escape and her remote start runs for roughly 15 minutes. Just nitpicking with that one.

One thing I have noticed since purchasing the vehicle is the random peaks in RPM while idle/parked. Usually it runs a little below 1k RPM, then for a short burst would go up to about 2k-2.5k RPM. I notice this more frequent when I have the AC running followed by a ticking sound as it comes down in RPM. The closest Mitsubishi dealership is roughly over an hour so I havent been able to get the chance to ask them yet. I forgot to mention the milage is at 38k.

My vehicle didn't come with any roof rails or rack but it does have that track with the rubber cover, least I think that's what it is. Is it possible to add a roof rack to this vehicle? If so what would I be looking for? I'm used to sedans so this is a bit different to anything I've driven before. I'm not looking to screw anything to the roof at all, don't trust myself to do it lol

Lastly, a couple weeks ago I noticed the check engine soon light on. I checked the filter, clean, and I also checked the gas cap, which might of been the cause, not 100% on that because it did turn off later on, not right away. Now the light is back on again and I did the same thing but havent seen it turn off yet, any common issues noted there? I understand that light could be a number of things so I'm not entirely asking for the solution, just some idea of what to look out for with this vehicle.

Thanks for taking the time to read this and if there is anything I left out I'll add them later below this as an edit.
 

·
Registered
Joined
·
514 Posts
Welcome @cmoorman91 to the forums. You can read about the install of the roof rails in this thread:


@Mistereman1 had success with the OEM rails he fitted to his EC. The description can be found on the second page of the thread. Enjoy...
 

·
Registered
2018 Mitsubishi Eclipse Cross SE
Joined
·
4 Posts
Discussion Starter · #3 ·
Welcome @cmoorman91 to the forums. You can read about the install of the roof rails in this thread:


@Mistereman1 had success with the OEM rails he fitted to his EC. The description can be found on the second page of the thread. Enjoy...
Thank you for your reply! I will look into this, much appreciated!
 

·
Super Moderator
Joined
·
381 Posts
Welcome fellow PA'ian.

I have a 2019 SEL with the touring package (pretty much every option) and I too had an issue with the connect app until I called them. I really think it's something to do with their server. Once they manually adjusted whatever settings they had to, it works without too much issue these days.

Can I ask why you want the car to idle for longer than 10 minutes? Unless it's -0°F or lower, you shouldn't need to warm it up at all. Just get in and drive modestly for the first mile or two. That's the best and fastest way to warm up a car. Idling for 10 minutes just wastes gas, IMHO.

The surging and check engine light concerns me. You might want to stop at an auto parts store and ask them to read the codes to see if they can narrow the issue down, and see if it's something you would have to take to the dealer. Honestly, if it's anything but reprogramming the ECU, any competent shop should be able to handle it.

Good luck.
 

·
Registered
Joined
·
357 Posts
Welcome to the Forum cmoormand91, and hope you enjoy it and find it useful.
Like Lunatic 59 I am concerned about the engine light coming on and hope you can get that sorted out quickly.
My EC has a manual gearbox, but believe the surging could be something to do with the CVT auto gearbox set-up, but sure others on here with more experience of your type of gearbox will be able to help you.
 

·
Registered
2018 Mitsubishi Eclipse Cross SE
Joined
·
4 Posts
Discussion Starter · #6 ·
Welcome fellow PA'ian.

I have a 2019 SEL with the touring package (pretty much every option) and I too had an issue with the connect app until I called them. I really think it's something to do with their server. Once they manually adjusted whatever settings they had to, it works without too much issue these days.

Can I ask why you want the car to idle for longer than 10 minutes? Unless it's -0°F or lower, you shouldn't need to warm it up at all. Just get in and drive modestly for the first mile or two. That's the best and fastest way to warm up a car. Idling for 10 minutes just wastes gas, IMHO.

The surging and check engine light concerns me. You might want to stop at an auto parts store and ask them to read the codes to see if they can narrow the issue down, and see if it's something you would have to take to the dealer. Honestly, if it's anything but reprogramming the ECU, any competent shop should be able to handle it.

Good luck.
Thanks for the reply

To start, I enjoy my drive to be toasty so an extra 5 min would do the trick I would think. It's not a big issue, more or less personal preference.

The check engine soon light isn't consistent. Like now today it's not on, it turned off sometime yesterday. When it comes on again I'm gonna have to have them read the code. Hopefully nothing too bad.

Welcome @cmoorman91 to the forums. You can read about the install of the roof rails in this thread:


@Mistereman1 had success with the OEM rails he fitted to his EC. The description can be found on the second page of the thread. Enjoy...
Just looked into that, doesnt seem too bad but the price is what's gonna kill. I'm gonna have to hold off on that. I was expect to pay the total price for what the price is for one of those. Not entirely double.
 

·
Super Moderator
Joined
·
381 Posts
he check engine soon light isn't consistent. Like now today it's not on, it turned off sometime yesterday. When it comes on again I'm gonna have to have them read the code. Hopefully nothing too bad.
The light will come on when there is something out of spec. and go out if the condition doesn't occur again within a specific period of time. It may be different for each trouble code. However, just because the light goes out doesn't mean the code is cleared. It's most likely still saved and you can find out what keeps triggering the light. My guess would be a loose vacuum hose. That could account for the surging as well.
 

·
Registered
2018 Mitsubishi Eclipse Cross SE
Joined
·
4 Posts
Discussion Starter · #8 ·
The light will come on when there is something out of spec. and go out if the condition doesn't occur again within a specific period of time. It may be different for each trouble code. However, just because the light goes out doesn't mean the code is cleared. It's most likely still saved and you can find out what keeps triggering the light. My guess would be a loose vacuum hose. That could account for the surging as well.
Sorry for the delay response, yeah the light hasn't come on since now. I thought it was the gas cap, I've been giving it a few extra clicks each time. My old car was a ford focus and it didnt have a cap on it, it was an anti theft cap or something. Opened only when a nozzle was inserted. I would like to check the vacuum hoses just to be sure. Would you have a diagram or even just a quick rundown of where I can check those? Thanks!
 

·
Registered
Joined
·
43 Posts
When this idle randomly increases what conditions are you in? After cold start? after a short run?

And how long does it idle for before this occurs?
 
1 - 10 of 10 Posts
Top