Eclipse Cross Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey everyone. I apologize if this has been asked before. I did look and couldn’t find anything.
I recently replaced my car battery. Everything works great but I have noticed now my Connect app will not connect to my car to do any of the subscription features. It can only locate my car. Has anyone had this problem? And if so, any suggestions on getting to work before calling?
 

·
Super Moderator
Joined
·
494 Posts
The connect app has always been buggy. I would definitely give Mitsubishi a call, but not the dealer. Use the connect button in your vehicle (not the emergency one).

When I had an issue the sent me these instructions and it worked for me. Might work for you, too.

1. Login To the My Mitsubishi Connect App
2. Click on the Settings icon
3. Once the Account Setting screen appears, please click on the "Manage Vehicles" section
4. On the Manage Vehicles screen, please toggle the setting for "Privacy Mode" until you see the grey section on the right of the switch turn red. You will need to enter your PIN for the setting to be modified and after the option has been enabled, you will receive a notification that "Privacy Mode enabled successfully"
5. Next, turn the privacy mode off. You will slide the button back to the left and you will see the red on the right of the button return to grey. You will receive a notification that "Privacy Mode disabled successfully"
6. Now back out of the Manage Vehicles section using the arrows until you have the icons at the bottom of the screen.
7. Click on the icon that looks like an arrow pointing up to the right, enter your PIN and the location of your vehicle should appear. If you get an error, please note the exact message you receive and reply to this message. Log out of the app completely and log back into the app
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
The connect app has always been buggy. I would definitely give Mitsubishi a call, but not the dealer. Use the connect button in your vehicle (not the emergency one).

When I had an issue the sent me these instructions and it worked for me. Might work for you, too.

1. Login To the My Mitsubishi Connect App
2. Click on the Settings icon
3. Once the Account Setting screen appears, please click on the "Manage Vehicles" section
4. On the Manage Vehicles screen, please toggle the setting for "Privacy Mode" until you see the grey section on the right of the switch turn red. You will need to enter your PIN for the setting to be modified and after the option has been enabled, you will receive a notification that "Privacy Mode enabled successfully"
5. Next, turn the privacy mode off. You will slide the button back to the left and you will see the red on the right of the button return to grey. You will receive a notification that "Privacy Mode disabled successfully"
6. Now back out of the Manage Vehicles section using the arrows until you have the icons at the bottom of the screen.
7. Click on the icon that looks like an arrow pointing up to the right, enter your PIN and the location of your vehicle should appear. If you get an error, please note the exact message you receive and reply to this message. Log out of the app completely and log back into the app
Thank you for the suggestion. My privacy mode can’t even switch over. It gives me an error. I have a ticket in with Mitsubishi connect. They are trying to figure it out. So once it’s starts working (I hope) I will post what they said for me to do. As of now everything they told me to do doesn’t work. Mitsubishi Connect suggested driving the car and then locking with key fob only and unlocking with key fob only, then after you have locked it try the app. I’ve been using it all week and it has never worked. Sucks since it isn’t a cheap service to purchase and it works only 1/2 the time.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Hey everyone. I apologize if this has been asked before. I did look and couldn’t find anything.
I recently replaced my car battery. Everything works great but I have noticed now my Connect app will not connect to my car to do any of the subscription features. It can only locate my car. Has anyone had this problem? And if so, any suggestions on getting to work before calling?
Well I have been working with Mitsubishi connect in this issue. They basically asked me if my SOS button was illuminated. It was not, so I replied back letting them know it was not. They literally replied with “We have exhausted all avenues, we are sorry we can’t help with this issue”. REALLY!!! The dealership (only one in Las Vegas bc they all shut down even the ones closest to me in St George closed down) was not able to do anything for me. They treated me like I was dumb for even asking them to look at it. They said it wasn’t their issue. It is Mitsubishi Connect. And now they are telling me it’s the dealerships issue. So I pay $300 a year for this service and now can’t use it and they won’t refund me the difference for having to cancel it since it won’t work! I’m beyond frustrated and so amazed that nothing can be done.
 

·
Super Moderator
Joined
·
494 Posts
Well I have been working with Mitsubishi connect in this issue. They basically asked me if my SOS button was illuminated. It was not, so I replied back letting them know it was not. They literally replied with “We have exhausted all avenues, we are sorry we can’t help with this issue”. REALLY!!! The dealership (only one in Las Vegas bc they all shut down even the ones closest to me in St George closed down) was not able to do anything for me. They treated me like I was dumb for even asking them to look at it. They said it wasn’t their issue. It is Mitsubishi Connect. And now they are telling me it’s the dealerships issue. So I pay $300 a year for this service and now can’t use it and they won’t refund me the difference for having to cancel it since it won’t work! I’m beyond frustrated and so amazed that nothing can be done.
That truly stinks. My experience with Mitsubishi connect was quite different. Dealers, OTOH can be real *** sometimes. I would contact a regional Mitsubishi office or corporate. The only email I was able to find was [email protected]

You could also try posting your problem on one of Mitsubishi's social media accounts. They don't like public negativity and have people monitoring those forums. Mitsubishi Motors Official Social Media | MITSUBISHI MOTORS
 
1 - 5 of 5 Posts
Top