Eclipse Cross Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
410 Posts
Hi @JL21 and welcome to the forums.

When you say the cable is missing do you mean the cable is not connected to the hood release handle by your left leg on the bottom of the A pillar? Did you buy your EC new or second hand? Seems strange that it would be disconnected and the dealer (new or second hand) did not know of the issue.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I've had this car for a couple of years but recently caught a flat on the highway and it tore up some wheel well which in turn tore off connections to my fog light to my blinker and apparently tore the cable out because it is no longer connected to the hood release lever in the car and I can't find it anywhere and obviously I can't open the hood
 

·
Registered
Joined
·
410 Posts
OK. Not good. My initial thought would be to remove the underbody splash guard and try to reach the latch from underneath but checking the online manuals shows they have installed a latch guard over the front to prevent this. Lists in the Tech Manual as a theft prevention measure. All other diagnostic measures list the requirement to remove the front section of the grille etc. so they are out of the question.

Do you know if the cable is pulled from the cabin lever or from the latch end? If it is the cabin lever end you can try removing the fender splash guard and see if you can manipulate the cable from outside the car. May well be a problem to give to the local dealership.
 
1 - 4 of 4 Posts
Top