Eclipse Cross Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Just got a new 2018 Cross in December. Trying to set up the Bluetooth and the sound only comes out of the front right side speaker and is super super low. Cannot hear the caller and they say they can barely hear me. The music is fine. Just the Bluetooth for phone. Took it to dealer, they tried it and agreed they could not hear the caller and the caller could not hear them. After speaking with Mitsubishi they said that was normal for the the 2018 Cross Bluetooth. I love the car but the Bluetooth is useless. Anyone else have this problem or are they giving me the runaround?
 

·
Registered
Joined
·
64 Posts
A workaround is to connect with Android Auto or Apple Carplay instead of over a raw Bluetooth connection. Phone calls come across loud and clear on all speakers with Android Auto.
 

·
Registered
Joined
·
77 Posts
Have you tried playing around with the fader in the settings while a call is active? I agree that connecting your phone directly is the better route to go. Seems like Mitsubishi cheaper out on their Bluetooth kit. Could always get a cheap aftermarket one if you prefer that setup.
 

·
Registered
Joined
·
1 Posts
I got the same issue with an Eclipse Cross 2020 I purchased in May/20.
Hello, did you find a solution for this yet?

I purchased myne in November and have the same issue. There is a setting to change it but it is greyed out.
 

·
Registered
mitsu eclipse cross gk my18
Joined
·
34 Posts
Hello, did you find a solution for this yet?

I purchased myne in November and have the same issue. There is a setting to change it but it is greyed out.
Hi,
I had similar problem when trying to connect my phone, could not connect all. Not quite the same problem but now my BT is coming throigh loud and clear when I finally got it sorteg. New to the forum so still learning how it all works but if you have a look at my intro (Gabe) you might find something there to help.
good luck and happy new year.
cheers
 

·
Registered
Joined
·
357 Posts
No problem here, phone works fine with Android Auto or on its own without a direct cable connection. My car first registered Sept 2019.
 
1 - 10 of 10 Posts
Top