Eclipse Cross Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Charging system warning light flickers, then 4 WD system service required, immediately 3 lights came on: ABS, ASC indicator and ASC indicator off (all three yellow) after 2 minutes car lost power on freeway, went from about 55mph to 25 mph and was able to get off freeway and park, turned off vehicle and started it again, no lights, but again in order it happened again, parked vehicle again and on the third try vehicle actually lost complete power and I had to park, where I was unable to start vehicle, got a tow and while awaiting tow car was able to start, but I decided to have it towed anyway because I knew all of this would happen again, now when I start car I see the illuminated light saying S-AWC, so as you can see it appears 6 different lights have illuminated leaving me just completely dumbfounded, any ideas of what the root problem is? Charging System warning light and service required light, ABS (anti lock breaking system warning light with ASC indicator active stability control along with ASC indicator off as well) all three come on and this is when the car begins to quickly lose all power and acceleration to where it needs to be parked immediately. and now the S-AWC light is on when car is turned on, super all wheel control, how many problems can one car have all at the same time?
 

·
Registered
Joined
·
12 Posts
This may sound ludicrous but have you checked to make sure you don't have any burned out bulbs or anything plugged into the OBDII port? The CANBUS system is especially finicky and burned out bulbs or OBDII devices have caused crazy errors in other Mitsubishi models.
 
1 - 6 of 6 Posts
Top