Eclipse Cross Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi guys newbie here. I got the eclipse cross 4 edition last year. Just the other day I got a warning light saying Tyre pressure monitor service required. I have tried inflating the Tyres and even resetting the ID. Which did work for like a day and then it came back on. Has anyone had this warning and know any more about it?
 

·
Registered
Joined
·
379 Posts
Have had a warning come on in very cold weather conditions, which can affect the tyre monitors. I raised the tyre pressures a little and that seemed to cure the problem. There is a warning in the handbook regarding low temperatures atmospheric conditions can cause this problem.
However you may just have a faulty monitor, which your dealer can sort out. Check your tyre pressure are at the correct settings though, before calling in the dealer.
 

·
Registered
Joined
·
126 Posts
Did you
Hi guys newbie here. I got the eclipse cross 4 edition last year. Just the other day I got a warning light saying Tyre pressure monitor service required. I have tried inflating the Tyres and even resetting the ID. Which did work for like a day and then it came back on. Has anyone had this warning and know any more about it?
Check your spare tyre.... there a 5th sensor in tyre
 

·
Registered
Joined
·
23 Posts
Just had this on the wife's Cross. Ended up being a broken sensor.

So far at 20k miles, I'm NOT impressed with this thing.
 
1 - 4 of 4 Posts
Top