Eclipse Cross Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi! Does anyone else have an issue with turning the key and the car not starting at all for several seconds? I've taken my car in 6 times for the issue, and it has not been fixed yet. The starter has been replaced as well as relays. The issue happens frequently, but not every time. Of course only happened once at service center.
 

·
Super Moderator
Joined
·
439 Posts
If you have a manual transmission, make sure the clutch is fully depressed. If you have an automatic, try starting it with the shift level in neutral instead of park. It sounds like a problem with the safety switch.
 

·
Registered
Joined
·
1 Posts
Hi! Does anyone else have an issue with turning the key and the car not starting at all for several seconds? I've taken my car in 6 times for the issue, and it has not been fixed yet. The starter has been replaced as well as relays. The issue happens frequently, but not every time. Of course only happened once at service center.
Hi I've had the same problem for about a year and a half. I've talk to Mitsubishi and open up a case in which they do nothing about. There was a dealership I took it to when I moved back to Ohio. They said it was a cold start issue. Did not fix the problem. They tell me everything checks out fine. They called corporate technician. At first they were not aware of any issue. The dealership said they got a different one. We are not the only one with the same problem. They tell you they are working on a fix that they will call you. Well that been since February 2020. Still no fix just angry customers and no solution. I'm surprised they replaced the starter no dealership has done any sort of work for me on the issue. Now it's a frequent thing I deal with on a daily basis. Keep up the fight.
 

·
Registered
Joined
·
2 Posts
Hi! Does anyone else have an issue with turning the key and the car not starting at all for several seconds? I've taken my car in 6 times for the issue, and it has not been fixed yet. The starter has been replaced as well as relays. The issue happens frequently, but not every time. Of course only happened once at service center.
I am taking mine in for this tomorrow. It is getting progressively worse and it is not that cold outside yet. Mine is automatic 2018 with 20,000 miles. Good to know that I'm not imaging it!!!
 

·
Registered
Joined
·
379 Posts
Have they checked that the fault is not the Ignition Switch itself. Maybe faulty contacts within the switch causing the problem. Or is that being too simple minded.
No problem here with the keyless entry system, just to make sure you fully depress the clutch pedal when pressing the start button.
 

·
Registered
Joined
·
379 Posts
Ah !! cheers. Great that they have found the problem. Hopefully you can now relax and enjoy your car once again.

Here's hoping that diagnosis will help Dee66 and Dmen1393 to sort their cars out also.
 
  • Like
Reactions: Lunatic59
1 - 7 of 7 Posts
Top